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Recommended PC requirements   
Operating System   Windows 10 64-bit   

Memory     8 GB   

Free Disk Space    100 GB 

Ethernet Ports    2 (1st port for Instrument, 2nd port for network access)   

  

Installation   
Open the installer file to start the installation. 

NOTE: ‘Check for Updates’ feature in Compass software will not update from version 3.x to version 

4.0.0 and higher. User will need to download installer from  Bio-Techne website (https://www.bio-

techne.com/resources/instrument-software-download-center) and perform a full installation. 

NOTE: If you are using Peggy Sue, Sally Sue or NP1000, Compass for Simple Western version 6.0 and 

higher does not support these instruments. You can still use software versions 5.x and lower to create, 

load and run assays on these instruments, and to analyze your data. 

   
 

6.3.0 Compass for SW 

Features 
 

1. Added the ability to manually adjust the start and end pixel position in analysis settings for 

Protein Normalization baseline (CSW-417). 

Improvements and Fixes 
General 

1. Compass for SW and Instrument user guides offline copies are no longer installed by default 

with Compass for SW installer. Latest user guides can be obtained from Bio-Techne website 

(CSW-425) 

2. Added informational message in instrument properties window to restart compass and 

instrument after selecting ‘Set to PC time’ button (CSW-426) 

3. Added a reminder in the Start UI dialog to fill all empty wells in rows that are being used in the 

assay before starting a run (CSW-520) 

4. Fixed issue with incorrect incubation wash steps generated by Compass for SW for Stellar 

assays. This issue occurs when new assay is created from File->New Assay Menu and the fix will 

not impact performance of runs already performed (CSW-457)  

https://www.bio-techne.com/resources/instrument-software-download-center
https://www.bio-techne.com/resources/instrument-software-download-center


5. Fixed the issue of the inability to select and copy multiple caps in Capillaries tab under ‘View 

Selected’ option (CSW-472, CSW-482) 

6. Fixed the annotation issue with probe 1 channel (s) selected for RePlex assays. Annotation can 

be done with either probe selection, ‘index out of bounds’ error no longer appears (CSW-353) 

7. Fixed the issue where IV plots are not exported into run report for certain runs (CSW-354) 

8. Fixed issue with contrast intensity of the ladder cap in lane view. Ladder cap intensity is now 

independent of rest of the caps and is set per peak fit view range in analysis settings, sample 

lane contrast is set per peak fit view range in analysis settings as well (CSW-499, CSW-500) 

9. Normalization settings of Stellar Total Protein runs are now added in the run report (CSW-498) 

10. Fixed the issue of Compass for SW displaying ‘Cannot connect to server’ warning dialog even 

when authentication server was connected (CSW-538).  

 

Known Issues 
 

General 

1. IV Plot title for Jess run displays "Cycle 1", instead of being blank (18962) 

2. History Log - Manual standard changes log message is not easily understandable. (18882) 

3. Add Run - Scale incorrect when run files of different sizes are added. (18915) 

4. Report will include legacy “Registration” Standards, although they are not used in analysis, nor 

are they visible in the Analysis Settings - Standards for Jess or Wes. (18836) 

5. If the user creates a name of the form Cn (such as C1) in the assay template, that name cannot 

be used in the Caps filter for Peak Names in Analysis Options (18753) 

6. Analysis Settings for Peak Names -> Standard Curves -> Concentration - units of precision do not 

match report. (18905) 

7. Analysis Settings for Peak Fit - Apply Override range changes are not properly applied to selected 

caps. (19024) 

8. It is possible for Peaks to be improperly labelled if user adds more manual peaks than there are 

ladder peaks. (18050)  

9. It is possible for the check-mark next to a ladder cap to not be removed when ladder peak 

changes are removed (18996) 

10. When trying to force a small/non-existent peak as a ladder peak, analysis will sometimes have 

issues finding the previous Ladder peaks 

Solution: Select Clear from context menu to remove the manual peak (19109) 

11. Electropherogram graph scaling issue when viewing multiple run files and one of the run files is 

not properly aligned to standards. (16351) 

12. Start Assay and Blot dialogs can be displayed at the same time. (17467) 

13. Plot Label display is cut off on left side of the plot when Ladder Capillary is set to ‘None’ and a 

single capillary is selected.  This only applies for Wes and Peggy Sue run files. (16850) 

14. ANDI export: In certain cases, peak positions may show slight difference between Compass for 

SW and Empower/Chromeleon due to peak detect/find algorithms with different software 

packages used for analysis (18873, 16048) 

15. Standard Curve tab disappears upon reanalysis of data if user selects to Cancel settings dialog 

Solution: Go to Edit > Analysis... > Standard Curve > OK (19012) 



16. Assay Template changes made during the run are not saved after the run completes (19050 or 

CSW-306)  

17. Plot labels are not displayed correctly (capillary and exposures) when Apply Colors to stacked 

plots graph options is selected in Preferences for any multichannel runs with RePlex (20835) 

18. Zoom out only works properly for first standard curve graph (21039) 

19. Signal to Noise settings – validation checks do not exist to ensure Start < End (21229) 

20. File > Close All does not close all run files if one of them needs to be saved (21320) 

21. Standard Curve tab disappears after user Adds Run without Std Curve and reanalysis is triggered 

on second run (21322) 

22. Channel Column appears for Peak Groups in Abby run file Reports (21341) 

23. Standards Graphs - Exposures in legends should be in black when the plots are stacked (21351) 

24. Lane selection for RePlex – Probe 2 lanes not selected if channel added after capillary selection 

done in Lane View (21388) 

25. Plot label color should be black for stacked plots when "Apply colors to stacked plots" is off 

(21394) 

26. Lane View – Probe 2 Ladder Lane location moves when user switches from "View All" to "View 

Selected" 

Solution: User can manually move the ladder lane to desired location (21410) 

27. File Open Recent List - file path is not correctly saved for folder name contains comma (21506) 

28. When Exposure settings contain decimal values, folder name created from ‘Export Tables’ action 

in Compass does not display decimals (21613). 

29. German language: Decimal point is not replaced by comma in export table (21673) and in the 

analysis settings fields of PDF report (21681) 

30. Corrected area column is missing when Normalization is enabled and when ladder cap is set as 

reference cap (21676 or CSW-567) 

31. Add runs – ‘save’, ‘close’ and ‘close all’ operations  

• Save button will not be enabled for Add Runs when only one file is modified (19042) 

Solution: Close the run file that has not been changed, this enables save button for the 

changed file. The user can then save and close. 

• Selecting File->Close All does not close all the files after saving (19048) 

• When two runs are open, selecting File->Close on a specific run will close the other run 

(21797). 

32. For Locale Chinese and Japanese, in assay perspective well name changes are not retained after 

Compass restarts. Report and export tables show empty well names (21677) 

33. Standards curve graph tab does not appear after an undo-redo action (CSW-72) 

Solution: Standards curve tab can be restored by opening analysis setting and clicking on ok 

button.  

34. In graphs view, when ‘stack plots’ view is on, consecutive zooming in multi-lane view resets 

initial zoom action on the Y-axis to display default scale. (CSW-289) 

35. Compass crashes with an internal error dialog when zoom action is performed repeatedly in the 

graph view in an empty graph area (CSW-313) 

Solution: Close the error dialog and launch Compass for SW again, there is no impact on run 

result data or analysis settings due to this issue. 

36. Export of analysis settings prompts to save in a path different from the run file path (CSW-317) 

Solution: One can navigate to intended path and save the analysis settings 



37. Independent Probe Scale option is checked in Lane View even after the setting was unchecked 

in Graph View (CSW-321)  

38. In images view, capillary selection on Probe 2 images disappears when navigated between 

standards and samples views (CSW-325)  

 

Lane Annotations 

NOTE: Software verification only performed on a limited set of font styles and sizes.  Some 

Windows fonts and large sizes will not display well, as with any other free form editing 

software.  Certain resolution size and scaling may also produce undesirable results, use 

Windows Recommended settings where possible. 

 

1. Custom Band Labels and MW Ladder can overlap when on same side of Figure image (21094) 

2. Lane/Band Labels and Notes can overlap for some fonts/sizes (21272) 

3. Cannot copy text to Windows clipboard from Notes or Labels (21289) 

4. Band Label Linked To field not updated properly after user modifies Peak Name settings (Group 

name, Peak name, MW) (21299) 

5. Lane labels and Caps list incorrect if user hides capillaries in Figure after being created (21316, 

21317) 

6. Lane Labels are not at the center of the lanes when rotated 45 degree (21327) 

7. Default locations for Lane Labels are in reversed order, comparing to Lane view (21348) 

8. Underlines are not aligned for angled and wrapped text Lane labels (21353) 

9. When adding new MW Region, sometimes the existing Regions will change if the software 

determines no empty region is available (21390) 

10. Exported .tiff image is roughly 50% smaller than .png or .jpg when copied into 

Word/PowerPoint/etc. (21391) 

11. In Notes section, cursor jumps to the beginning of the Notes after "#cbz" button is clicked 

(21454) 

12. When the ladder probe is changed by the user in Analysis Settings, Lane capillary is updated but 

the Band Labels are not displayed properly 

Solution: Perform Re-crop to update the Figure Band Label displays (21440) 

13. For RePlex runs when “Independent Probe Scale” setting is Off and the user modifies the 

Contrast in the Lane View, the newly created Figures don’t have the same contrast  

Solution: Use Custom Contrast in Crop Regions to adjust contrast as desired (21455) 

 

RePlex™ 

1. Plot colors for RePlex runs may not be in the order expected. (18943) 

2. For RePlex assay data, Loading Controls can be used to correct the peaks of the same capillary, 

for both Probe 1 and Probe 2.  When multiple Loading Controls are defined across Probes, 

corrected area results for some capillaries can be incorrect (18989) 

3. Unable to make manual ladder changes for ladder capillary for RePlex assays with Total Protein 

when all channels are selected. 

Solution: Temporarily unselect the Total Protein channel, then the context menu appears, 

allowing the user to make any necessary changes (19434) 



 

Lane 

1. Named Peaks are not displayed in Lane View when viewing multiple run files, even if the Named 

Peaks option in Lane Label dialog is selected. (16227) 

2. Contrast enhancement tool in Lane View is currently implemented for single run file only, does 

not work as expected when viewing data from multiple run files via Add Run capability 

Solution: Use the same fixed contrast levels for added runs (16226) 

3. Lane order resets when user switches View from Single to All (21270) 

4. Lane order resets after user changes Lane Options (21271) 

 

History 

1. Lane View Options and Graph view option changes are not saved correctly in History log (21443) 

Solution: Pre-existing access-controlled Jess non-Replex assays that were created with versions 

earlier than 6.1 will have this issue. If history log entries are critical to the system, perform an 

initial save of the assay file. Logs of any changes after the first save will be displayed correctly.  

2. Removal of Peak name groups entries are not logged (21692). 

 

6.2.0 Compass for SW 

Features 
 

1. Added Manual Peak Integration feature. Peak area can now be adjusted by dragging start and 

end of the peak when ‘Dropped Lines (manual)’ option is selected under Peak Find analysis 

settings (CSW-1) 

2. Added new ‘Interpolate’ option for Baseline type in Peak Fit analysis settings. When selected, 

Compass for SW lets you interpolate baselines from the base of each peak when chosen fit 

types are Dropped Lines or Dropped Lines (manual) (CSW-10) 

3. Added ability to perform undo - redo actions within Compass for SW for assay and analysis 

views (CSW-92) 

4. Added Ability to adjust peak table columns (peaks, capillaries, and experiment tables) in the 

analysis view (CSW-132).  

Note: These column selections are limited to Compass views only, not reflected in exports and 

reports. 

Improvements and Fixes 
General 

1. Help resources are moved to Bio-Techne website as proteinsimple.com site retired (CSW-80) 

2. Removed unused Log4j library from code to avoid any vulnerability threats (CSW-93)  

3. Bio-Techne Academy link is added in the help menu to provide easy access to learning portal 

(CSW-96) 

 

 RePlex™ 



1. In some Re-Plex standards run, Y-axis displays chemi units instead of Fluorescence (21429 or 

CSW-52) 

2. Corrected default Peak Fit settings for Low MW assays so that they are the same for Abby and 

Jess, with or without Total Protein (CSW-74) 

3. Fixed issue with missing Total Protein data after generating std curves in Jess RePlex TP run 

(CSW-450) 

 

Known Issues 
 

General 

1. IV Plot title for Jess run displays "Cycle 1", instead of being blank (18962) 

2. History Log - Manual standard changes log message is not easily understandable. (18882) 

3. Add Run - Scale incorrect when run files of different sizes are added. (18915) 

4. Report will include legacy “Registration” Standards, although they are not used in analysis, nor 

are they visible in the Analysis Settings - Standards for Jess or Wes. (18836) 

5. If the user creates a name of the form Cn (such as C1) in the assay template, that name cannot 

be used in the Caps filter for Peak Names in Analysis Options (18753) 

6. Analysis Settings for Peak Names -> Standard Curves -> Concentration - units of precision do not 

match report. (18905) 

7. Analysis Settings for Peak Fit - Apply Override range changes are not properly applied to selected 

caps. (19024) 

8. It is possible for Peaks to be improperly labelled if user adds more manual peaks than there are 

ladder peaks. (18050)  

9. It is possible for the check-mark next to a ladder cap to not be removed when ladder peak 

changes are removed (18996) 

10. When trying to force a small/non-existent peak as a ladder peak, analysis will sometimes have 

issues finding the previous Ladder peaks 

Solution: Select Clear from context menu to remove the manual peak (19109) 

11. Electropherogram graph scaling issue when viewing multiple run files and one of the run files is 

not properly aligned to standards. (16351) 

12. Start Assay and Blot dialogs can be displayed at the same time. (17467) 

13. Plot Label display is cut off on left side of the plot when Ladder Capillary is set to ‘None’ and a 

single capillary is selected.  This only applies for Wes and Peggy Sue run files. (16850) 

14. ANDI export: In certain cases, peak positions may show slight difference between Compass for 

SW and Empower/Chromeleon due to peak detect/find algorithms with different software 

packages used for analysis (18873, 16048) 

15. Standard Curve tab disappears upon reanalysis of data if user selects to Cancel settings dialog 

Solution: Go to Edit > Analysis... > Standard Curve > OK (19012) 

16. Assay Template changes made during the run are not saved after the run completes (19050 or 

CSW-306)  

17. Plot labels are not displayed correctly (capillary and exposures) when Apply Colors to stacked 

plots graph options is selected in Preferences for any multichannel runs with RePlex (20835) 

18. Zoom out only works properly for first standard curve graph (21039) 

19. Signal to Noise settings – validation checks do not exist to ensure Start < End (21229) 



20. File > Close All does not close all run files if one of them needs to be saved (21320) 

21. Standard Curve tab disappears after user Adds Run without Std Curve and reanalysis is triggered 

on second run (21322) 

22. Channel Column appears for Peak Groups in Abby run file Reports (21341) 

23. Standards Graphs - Exposures in legends should be in black when the plots are stacked (21351) 

24. Lane selection for RePlex – Probe 2 lanes not selected if channel added after capillary selection 

done in Lane View (21388) 

25. Plot label color should be black for stacked plots when "Apply colors to stacked plots" is off 

(21394) 

26. Lane View – Probe 2 Ladder Lane location moves when user switches from "View All" to "View 

Selected" 

Solution: User can manually move the ladder lane to desired location (21410) 

27. File Open Recent List - file path is not correctly saved for folder name contains comma (21506) 

28. When Exposure settings contain decimal values, folder name created from ‘Export Tables’ action 

in Compass does not display decimals (21613). 

29. German language: Decimal point is not replaced by comma in export table (21673) and in the 

analysis settings fields of PDF report (21681) 

30. Corrected area column is missing when Normalization is enabled and when ladder cap is set as 

reference cap (21676) 

31. Add runs – ‘save’, ‘close’ and ‘close all’ operations  

• Save button will not be enabled for Add Runs when only one file is modified (19042) 

Solution: Close the run file that has not been changed, this enables save button for the 

changed file. The user can then save and close. 

• Selecting File->Close All does not close all the files after saving (19048) 

• When two runs are open, selecting File->Close on a specific run will close the other run 

(21797). 

32. For Locale Chinese and Japanese, in assay perspective well name changes are not retained after 

Compass restarts. Report and export tables show empty well names (21677) 

33. Standards curve graph tab does not appear after an undo-redo action (CSW-72) 

Solution: Standards curve tab can be restored by opening analysis setting and clicking on ok 

button.  

34. In graphs view, when ‘stack plots’ view is on, consecutive zooming in multi-lane view resets 

initial zoom action on the Y-axis to display default scale. (CSW-289) 

35. Compass crashes with an internal error dialog when zoom action is performed repeatedly in the 

graph view in an empty graph area (CSW-313) 

Solution: Close the error dialog and launch Compass for SW again, there is no impact on run 

result data or analysis settings due to this issue. 

36. Export of analysis settings prompts to save in a path different from the run file path (CSW-317) 

Solution: One can navigate to intended path and save the analysis settings 

37. Independent Probe Scale option is checked in Lane View even after the setting was unchecked 

in Graph View (CSW-321)  

38. In images view, capillary selection on Probe 2 images disappears when navigated between 

standards and samples views (CSW-325)  

 



Lane Annotations 

NOTE: Software verification only performed on a limited set of font styles and sizes.  Some 

Windows fonts and large sizes will not display well, as with any other free form editing 

software.  Certain resolution size and scaling may also produce undesirable results, use 

Windows Recommended settings where possible. 

 

1. Custom Band Labels and MW Ladder can overlap when on same side of Figure image (21094) 

2. Lane/Band Labels and Notes can overlap for some fonts/sizes (21272) 

3. Cannot copy text to Windows clipboard from Notes or Labels (21289) 

4. Band Label Linked To field not updated properly after user modifies Peak Name settings (Group 

name, Peak name, MW) (21299) 

5. Lane labels and Caps list incorrect if user hides capillaries in Figure after being created (21316, 

21317) 

6. Lane Labels are not at the center of the lanes when rotated 45 degree (21327) 

7. Default locations for Lane Labels are in reversed order, comparing to Lane view (21348) 

8. Underlines are not aligned for angled and wrapped text Lane labels (21353) 

9. When adding new MW Region, sometimes the existing Regions will change if the software 

determines no empty region is available (21390) 

10. Exported .tiff image is roughly 50% smaller than .png or .jpg when copied into 

Word/PowerPoint/etc. (21391) 

11. In Notes section, cursor jumps to the beginning of the Notes after "#cbz" button is clicked 

(21454) 

12. When the ladder probe is changed by the user in Analysis Settings, Lane capillary is updated but 

the Band Labels are not displayed properly 

Solution: Perform Re-crop to update the Figure Band Label displays (21440) 

13. For RePlex runs when “Independent Probe Scale” setting is Off and the user modifies the 

Contrast in the Lane View, the newly created Figures don’t have the same contrast  

Solution: Use Custom Contrast in Crop Regions to adjust contrast as desired (21455) 

 

RePlex™ 

1. Plot colors for RePlex runs may not be in the order expected. (18943) 

2. For RePlex assay data, Loading Controls can be used to correct the peaks of the same capillary, 

for both Probe 1 and Probe 2.  When multiple Loading Controls are defined across Probes, 

corrected area results for some capillaries can be incorrect (18989) 

3. Unable to make manual ladder changes for ladder capillary for RePlex assays with Total Protein 

when all channels are selected. 

Solution: Temporarily unselect the Total Protein channel, then the context menu appears, 

allowing the user to make any necessary changes (19434) 

 

Lane 

1. Named Peaks are not displayed in Lane View when viewing multiple run files, even if the Named 

Peaks option in Lane Label dialog is selected. (16227) 



2. Contrast enhancement tool in Lane View is currently implemented for single run file only, does 

not work as expected when viewing data from multiple run files via Add Run capability 

Solution: Use the same fixed contrast levels for added runs (16226) 

3. Lane order resets when user switches View from Single to All (21270) 

4. Lane order resets after user changes Lane Options (21271) 

 

History 

1. Lane View Options and Graph view option changes are not saved correctly in History log (21443) 

Solution: Pre-existing access-controlled Jess non-Replex assays that were created with versions 

earlier than 6.1 will have this issue. If history log entries are critical to the system, perform an 

initial save of the assay file. Logs of any changes after the first save will be displayed correctly.  

2. Removal of Peak name groups entries are not logged (21692). 

 

6.1.0 Compass for SW 

Features 
 

1. Support for the new Stellar assays 

2. New image analysis option - High Dynamic Range (HDR) for Jess fluorescence images 

Note: The HDR method uses information from multiple exposures to achieve good signal-to-

noise for low protein concentration while simultaneously maintaining signal monotonicity at 

high protein concentration. 

3. Jess and Abby RePlex assays are now supported with Access Control Enabled. 

4. Saturation warning in experiment tables and red pixel overlay on the Image view when ‘Show 

All Images’ is enabled. 

5. Support to display both 10-Digit and 11-Digit plate serial number of the assays in the run 

summary.  

Note: When new plates with 11-digit barcode are used with Compass SW 6.0 or older version of 

software, 'Confirm plate type matches assay' informational message will appear in Jess Start 

Run dialog window. 

Improvements and Fixes 
 

General 

1. Updated compass to prevent saving an assay file with invalid well locations (19076) 

2. Wes Assay Template Sample Name changes are saved properly (21656) 

3. Assay Copy Template - fixed too much white space below the template (21573) 

4. Fixed issue - Default Analysis View Options should not be changed for the runs (21447) 

 Note: Default Analysis View Options are now in sync with assays, not the ones changed for the 

runs 

5. Updated immobilization step for Jess assays to improve instrument performance (21643) 

Note: When using existing Jess or Wes assay files in Jess instrument, user will now see a prompt 

to confirm assay change before performing a run using it (21650). 



6. Updated compass to ensure changing exposure for one channel does not impact the lane 

contrasts of other channels (21548) 

7. When Protein Normalization channel is enabled and Normalization is turned Off, PN and PN (%) 

numbers are shown (21449) 

8. In Image view, enabled image “Copy” context option (21360) 

9. Change default S/N methods to "Signal-to-Noise Ratio" for Jess default assays (21522).  

   Note: S/N method “Peak Score (v1-v5)” is renamed to “S/N Compass v5.0” (21659) 

10. Enabled turning on/off the password protection of Run Report PDF files, default is on (21579) 

11. Abby: Updated to ensure separation movie displays all caps during separation step (21500) 

12. Fixed run completed time display issue - run completion time now includes cleanup cycle end 

time (21538) 

13. Fixed the intermittent ‘Null Pointer Exception’ and ‘Graphic is Disposed’ internal error dialog 

issues when playing movie after switching between assay and run views while the instrument is 

running (21701, 20795) 

14. Fixed the issue with Lane view image display - In Lane view of Replex TP runs, when only ‘TP 

Channel’ is selected, Lane view image doesn’t update to show selected caps when multiple caps 

are selected (21834) 

 

History 

1. Enabled logging of Lane contrast changes in analysis dialog (21108) 

2. Apply Settings action is added in History for new Peak Name group for Wes run files (21380) 

3. Additional Graph and Lane View options logged in History (21338) 

4. Improved image exposure history log entries (21399, 21403, 19056) 

5. Log lane contrast setting changes – fixed values and slider levels (19086) 

 

  



Known Issues 
 

General 

1. IV Plot title for Jess run displays "Cycle 1", instead of being blank (18962) 

2. History Log - Manual standard changes log message is not easily understandable. (18882) 

3. Add Run - Scale incorrect when run files of different sizes are added. (18915) 

4. Report will include legacy “Registration” Standards, although they are not used in analysis, nor 

are they visible in the Analysis Settings - Standards for Jess or Wes. (18836) 

5. If the user creates a name of the form Cn (such as C1) in the assay template, that name cannot 

be used in the Caps filter for Peak Names in Analysis Options (18753) 

6. Analysis Settings for Peak Names -> Standard Curves -> Concentration - units of precision do not 

match report. (18905) 

7. Analysis Settings for Peak Fit - Apply Override range changes are not properly applied to selected 

caps. (19024) 

8. It is possible for Peaks to be improperly labelled if user adds more manual peaks than there are 

ladder peaks. (18050)  

9. It is possible for the check-mark next to a ladder cap to not be removed when ladder peak 

changes are removed (18996) 

10. When trying to force a small/non-existent peak as a ladder peak, analysis will sometimes have 

issues finding the previous Ladder peaks 

Solution: Select Clear from context menu to remove the manual peak (19109) 

11. Electropherogram graph scaling issue when viewing multiple run files and one of the run files is 

not properly aligned to standards. (16351) 

12. Start Assay and Blot dialogs can be displayed at the same time. (17467) 

13. Plot Label display is cut off on left side of the plot when Ladder Capillary is set to ‘None’ and a 

single capillary is selected.  This only applies for Wes and Peggy Sue run files. (16850) 

14. ANDI export: In certain cases, peak positions may show slight difference between Compass for 

SW and Empower/Chromeleon due to peak detect/find algorithms with different software 

packages used for analysis (18873, 16048) 

15. Standard Curve tab disappears upon reanalysis of data if user selects to Cancel settings dialog 

Solution: Go to Edit > Analysis... > Standard Curve > OK (19012) 

16. Assay Template changes made during run are not saved after the run completes (19050)  

17. Plot labels are not displayed correctly (capillary and exposures) when Apply Colors to stacked 

plots graph options is selected in Preferences for any multichannel runs with RePlex (20835) 

18. Zoom out only works properly for first standard curve graph (21039) 

19. Signal to Noise settings – validation checks do not exist to ensure Start < End (21229) 

20. File > Close All does not close all run files if one of them needs to be saved (21320) 

21. Standard Curve tab disappears after user Adds Run without Std Curve and reanalysis is triggered 

on second run (21322) 

22. Channel Column appears for Peak Groups in Abby run file Reports (21341) 

23. Standards Graphs - Exposures in legends should be in black when the plots are stacked (21351) 

24. Lane selection for RePlex – Probe 2 lanes not selected if channel added after capillary selection 

done in Lane View (21388) 



25. Plot label color should be black for stacked plots when "Apply colors to stacked plots" is off 

(21394) 

26. Lane View – Probe 2 Ladder lane location moves when user switches from "View All" to "View 

Selected" 

Solution: User can manually move the ladder lane to desired location (21410) 

27. File Open Recent List - file path is not correctly saved for folder name contains comma (21506) 

28. When Exposure settings contain decimal values, folder name created from ‘Export Tables’ action 

in Compass does not display decimals (21613). 

29. German language: Decimal point is not replaced by comma in export table (21673) and in the 

analysis settings fields of PDF report (21681) 

30. Corrected area column is missing when Normalization is enabled and when ladder cap is set as 

reference cap (21676) 

31. Add runs – ‘save’, ‘close’ and ‘close all’ operations  

• Save button will not be enabled for Add Runs when only one file is modified (19042) 

Solution: Close the run file that has not been changed, this enables save button for the 

changed file. The user can then save and close. 

• Selecting File->Close All does not close all the files after saving (19048) 

• When two runs are open, selecting File->Close on a specific run will close the other 

run(21797). 

32. For Locale Chinese and Japanese, in assay perspective well name changes are not retained after 

compass restarts. Report and export tables show empty well names (21677) 

 

Lane Annotations 

NOTE: Software verification only performed on a limited set of font styles and sizes.  Some 

Windows fonts and large sizes will not display well, as with any other free form editing 

software.  Certain resolution size and scaling may also produce undesirable results, use 

Windows Recommended settings where possible. 

 

1. Custom Band Labels and MW Ladder can overlap when on same side of Figure image (21094) 

2. Lane/Band Labels and Notes can overlap for some fonts/sizes (21272) 

3. Cannot copy text to Windows clipboard from Notes or Labels (21289) 

4. Band Label Linked To field not updated properly after user modifies Peak Name settings (Group 

name, Peak name, MW) (21299) 

5. Lane labels and Caps list incorrect if user hides capillaries in Figure after being created (21316, 

21317) 

6. Lane Labels are not at the center of the lanes when rotated 45 degree (21327) 

7. Default locations for Lane Labels are in reversed order, comparing to Lane view (21348) 

8. Underlines are not aligned for angled and wrapped text Lane labels (21353) 

9. When adding new MW Region, sometimes the existing Regions will change if the software 

determines no empty region is available (21390) 

10. Exported .tiff image is roughly 50% smaller than .png or .jpg when copied into 

Word/PowerPoint/etc. (21391) 



11. In Notes section, cursor jumps to the beginning of the Notes after "#cbz" button is clicked 

(21454) 

12. When the ladder probe is changed by the user in Analysis Settings, Lane capillary is updated but 

the Band Labels are not displayed properly 

Solution: Perform Re-crop to update the Figure Band Label displays (21440) 

13. For RePlex runs when “Independent Probe Scale” setting is Off and the user modifies the 

Contrast in the Lane View, the newly created Figures don’t have the same contrast  

Solution: Use Custom Contrast in Crop Regions to adjust contrast as desired (21455) 

 

RePlex™ 

1. Plot colors for RePlex runs may not be in the order expected. (18943) 

2. For RePlex assay data, Loading Controls can be used to correct the peaks of the same capillary, 

for both Probe 1 and Probe 2.  When multiple Loading Controls are defined across Probes, 

corrected area results for some capillaries can be incorrect (18989) 

3. Unable to make manual ladder changes for ladder capillary for RePlex assays with Total Protein 

when all channels are selected. 

Solution: Temporarily unselect the Total Protein channel, then the context menu appears, 

allowing the user to make any necessary changes (19434) 

 

Lane 

1. Named Peaks are not displayed in Lane View when viewing multiple run files, even if the Named 

Peaks option in Lane Label dialog is selected. (16227) 

2. Contrast enhancement tool in Lane View is currently implemented for single run file only, does 

not work as expected when viewing data from multiple run files via Add Run capability 

Solution: Use the same fixed contrast levels for added runs (16226) 

3. Lane order resets when user switches View from Single to All (21270) 

4. Lane order resets after user changes Lane Options (21271) 

 

History 

1. Lane View Options and Graph view option changes are not saved correctly in History log (21443) 

Solution: Pre-existing access-controlled Jess non-Replex assays that were created with versions 

earlier than 6.1 will have this issue. If history log entries are critical to the system, perform an 

initial save of the assay file. Logs of any changes after the first save will be displayed correctly.  

2. Removal of Peak name groups entries are not logged (21692). 

 

  



2.1 Jess Instrument Software 
NOTE: Requires Compass for SW version 6.1 for Stellar assays.   

Features 
 

1. Instrument support for Stellar assay (19282) 

 

Improvements and Fixes 
 

1. Self-test improvements – enhanced instrument logs 

Known Issues 
 

1. On rare occasions when attempting to close the door, the instrument will not properly 

recognize the hand sensor input and close (17590) 

2. When a run is performed with chemi detection setting other than HDR in the detection profile 

of Jess assay, chemi channel will not show any data (ESW-142). 

Solution: Select High Dynamic Range (HDR) as the Chemi Detection profile to perform chemi 

based runs on Jess. Details of HDR can be found in Compass for SW user guide.  

 

6.0.0 Compass for SW 
NOTE: If you are using Peggy Sue, Sally Sue or NP1000, Compass for Simple Western version 6.0 and 

higher does not support these instruments. You can still use software versions 5.x and lower to create, 

load and run assays on these instruments, and to analyze your data. 

Features 
 

1. Support for the new Abby instrument 

2. New Lane Annotation tools: Create annotated figures of the Compass Lane view for use in 

presentations and publications, saving you the hours it would take to manually annotate data 

using other programs. 

3. Analysis perspective Graph Options and Lane Options selections are now saved with the run 

file, so that user preferences are saved for the next time the run file is opened (19314) 

4. Change default Lane View to not show baseline corrected data.  Additionally, move Baseline 

On/Off to Lane Options to support ability to save options with run file (19310, 19566) 

5. Default Analysis View options: Graph and Lane View options are saved, created an interface for 

the default settings, under Edit -> Default Analysis View … (20742) 

6. Support new S/N algorithm improvements, with ability to use existing Compass for SW Peak 

Score algorithm in versions 5.x and earlier (19289) 

 

Improvements and Fixes 
 

General 



1. Improved performance of Lane View display, now with faster rendering of images and overall 

responsiveness for user interactions 

2. Analysis Setting for Peak Names - Loading Controls does not match report (18903) 

3. Help menu - Check for Updates, Export Logs and Send Run File options should be disabled 

during run (18913) 

4. Ladder cap should be excluded in Analysis Options -> Peak Names (18944) 

5. Capillaries table: Peak Names that are not assigned to Loading control should not be highlighted 

when Corr. Area is selected (18950) 

6. Capillary Groups will not display Rows & Channels for empty groups. (18967, 18969) 

7. Fixed display issue of overlapping peak labels for peaks at same MW in different probes (19621) 

8. Fixed issue where user could not properly save the run file when using File > Save As… on a file 

that has the Read-Only attribute set (20806) 

9. Standards Graphs - legends are all black for overlay/stacked graphs - should be colored per data 

trace color (20808) 

 

RePlex™ 

1. RePlex runs with Total Protein should not display Peak data for Probe 2 Ladder capillary (21195) 

2. RePlex runs with Total Protein should not export Primary in Peaks table (21196) 

3. RePlex Probe 2 trace colors in report do not match the trace color in Compass (19376) 

4. Graph - IR Probe 2 default color is the same as NIR Probe 1 (18993) 

5. Peaks table displays Probe 2 Total Protein data for ladder cap (18966) 

6. Export: %Total is displayed as 0.0 in Compass for Probe 2 data but in export it is empty (21197) 

7. Resolved issue with an incorrect baseline for RePlex Chemi with Total Protein run files.  This was 

an error introduced with the Hot Fix for 19257 in version 5.0.1 (19607) 

 

History 

1. History Log does not display old and new values when contrast is changed in Analysis Settings 

(Edit > Analysis > Lane Contrast) (21108) 

 

Known Issues 
 

General 

1. IV Plot title for Jess run displays "Cycle 1", instead of being blank (18962) 

2. History Log - Manual standard changes log message is not easily understandable. (18882) 

3. Add Run - Scale incorrect when run files of different sizes are added. (18915) 

4. Report will include legacy “Registration” Standards, although they are not used in analysis, nor 

are they visible in the Analysis Settings - Standards for Jess or Wes. (18836) 

5. If the user creates a name of the form Cn (such as C1) in the assay template, that name cannot 

be used in the Caps filter for Peak Names in Analysis Options (18753) 

6. Analysis Settings for Peak Names -> Standard Curves -> Concentration - units of precision do not 

match report. (18905) 

7. Analysis Settings for Peak Fit - Apply Override range changes are not properly applied to selected 

caps. (19024) 



8. It is possible for Peaks to be improperly labelled if user adds more manual peaks than there are 

ladder peaks. (18050)  

9. It is possible for the check-mark next to a ladder cap to not be removed when ladder peak 

changes are removed (18996) 

10. When trying to force a small/non-existent peak as a ladder peak, analysis will sometimes have 

issues finding the previous Ladder peaks 

Solution: Select Clear from context menu to remove the manual peak (19109) 

11. Electropherogram graph scaling issue when viewing multiple run files and one of the run files is 

not properly aligned to standards. (16351) 

12. Start Assay and Blot dialogs can be displayed at the same time. (17467) 

13. Plot Label display is cut off on left side of the plot when Ladder Capillary is set to ‘None’ and a 

single capillary is selected.  This only applies for Wes and Peggy Sue run files. (16850) 

14. ANDI export: In certain cases, peak positions may show slight difference between Compass for 

SW and Empower/Chromeleon due to peak detect/find algorithms with different software 

packages used for analysis (18873, 16048) 

15. When Protein Normalization channel is enabled and Normalization is turned Off, PN and PN (%) 

numbers are shown (21449) 

16. Standard Curve tab disappears upon reanalysis of data if user selects to Cancel settings dialog 

Solution: Go to Edit > Analysis... > Standard Curve > OK (19012) 

17. Assay Template changes made during run are not saved after the run completes (19050)  

18. Should not allow assay Save/Save As with invalid locations (19076) 

19. ‘Internal Error: Graphic is Disposed’ error displayed when attempting to play Separation movie 

during an Abby run (20795) 

20. Plot labels are not displayed correctly (capillary and exposures) when Apply Colors to stacked 

plots graph options is selected in Preferences for any multichannel runs with RePlex (20835) 

21. Zoom out only works properly for first standard curve graph (21039, 21412) 

22. Signal to Noise settings – validation checks do not exist to ensure Start < End (21229) 

23. File > Close All does not close all run files if one of them needs to be saved (21320) 

24. Standard Curve tab disappears after user Adds Run without Std Curve and reanalysis is triggered 

on second run (21322) 

25. Channel Column appears for Peak Groups in Abby run file Reports (21341) 

26. Standards Graphs - Exposures in legends should be in black when the plots are stacked (21351) 

27. Image View Copy context menu option is disabled for Jess/Abby run files (21360) 

28. Lane selection for RePlex – Probe 2 lanes not selected if channel added after capillary selection 

done in Lane View (21388) 

29. Plot label color should be black for stacked plots when "Apply colors to stacked plots" is off 

(21394) 

30. Default Analysis View Options UI display becomes out of sync after View Options are saved in 

the run file.  This is a UI display issue ONLY, as the View options in the Assay saved with the run 

(*.cbz) are correct (21447) 

31. Lane View – Probe 2 Ladder lane location moves when user switches from "View All" to "View 

Selected" 

Solution: User can manually move the ladder lane to desired location (21410) 

32. File Open Recent List - file path is not correctly saved for folder name contains comma (21506) 



33. German language: Decimal point is not replaced by comma in export table (21673) and in the 

analysis settings fields of PDF report (21681) 

  



34. Add runs – ‘save’ and ‘close all’ operations  

• Save button will not be enabled for Add Runs when only one file is modified (19042) 

Solution: Close the run file that has not been changed, this enables save button for the 

changed one. The user can then save and close. 

• Selecting File->Close All does not close all the files after saving (19048) 

 

Lane Annotations 

NOTE: Software verification only performed on a limited set of font styles and sizes.  Some 

Windows fonts and large sizes will not display well, as with any other free form editing 

software.  Certain resolution size and scaling may also produce undesirable results, use 

Windows Recommended settings where possible. 

 

1. Custom Band Labels and MW Ladder can overlap when on same side of Figure image (21094) 

2. Lane/Band Labels and Notes can overlap for some fonts/sizes (21272) 

3. Cannot copy text to Windows clipboard from Notes or Labels (21289) 

4. Band Label Linked To field not updated properly after user modifies Peak Name settings (Group 

name, Peak name, MW) (21299) 

5. Lane labels and Caps list incorrect if user hides capillaries in Figure after being created (21316, 

21317) 

6. Lane Labels are not at the center of the lanes when rotated 45 degree (21327) 

7. Default locations for Lane Labels are in reversed order, comparing to Lane view (21348) 

8. Underlines are not aligned for angled and wrapped text Lane labels (21353) 

9. When adding new MW Region, sometimes the existing Regions will change if the software 

determines no empty region is available (21390) 

10. Exported .tiff image is roughly 50% smaller than .png or .jpg when copied into 

Word/PowerPoint/etc. (21391) 

11. In Notes section, cursor jumps to the beginning of the Notes after "#cbz" button is clicked 

(21454) 

12. When the ladder probe is changed by the user in Analysis Settings, Lane capillary is updated but 

the Band Labels are not displayed properly 

Solution: Perform Re-crop to update the Figure Band Label displays (21440) 

13. For RePlex runs when “Independent Probe Scale” setting is Off and the user modifies the 

Contrast in the Lane View, the newly created Figures don’t have the same contrast  

Solution: Use Custom Contrast in Crop Regions to adjust contrast as desired (21455) 

 

RePlex™ 

1. Plot colors for RePlex runs may not be in the order expected. (18943) 

2. For RePlex assay data, Loading Controls can be used to correct the peaks of the same capillary, 

for both Probe 1 and Probe 2.  When multiple Loading Controls are defined across Probes, 

corrected area results for some capillaries can be incorrect (18989) 

3. Unable to make manual ladder changes for ladder capillary for RePlex assays with Total Protein 

when all channels are selected 



Solution: Temporarily unselect the Total Protein channel, then the context menu appears, 

allowing the user to make any necessary changes (19434) 

4. In some Re-Plex standards run, Y-axis displays chemi units instead of Fluorescence (21429) 

 

Lane 

1. Named Peaks are not displayed in Lane View when viewing multiple run files, even if the Named 

Peaks option in Lane Label dialog is selected. (16227) 

2. Contrast enhancement tool in Lane View is currently implemented for single run file only, does 

not work as expected when viewing data from multiple run files via Add Run capability 

Solution: Use the same fixed contrast levels for added runs (16226) 

3. Lane order resets when user switches View from Single to All (21270) 

4. Lane order resets after user changes Lane Options (21271) 

 

History 

1. Apply Settings not included in History for new Peak Name group for Wes run files (21380) 

2. Additional Graph and Lane View options logged in History (21338) 

3. In some cases, History does not properly show changes for Image exposure selection for Probe 2 

(21399, 21403) 

 

1.3 Abby Instrument Software 
NOTE: Requires Compass for SW version 6.0 or higher 

Features 
 

1. Support for new Abby instrument 

 

Known Issues 
 

1. None 

 

5.0.1 Compass for SW Released October 6, 2020 

Improvements and Fixes 
 

General 

1. Fixed issue where calculated Molecular Weight values are incorrect for peaks detected in Probe 

1 and Probe 2 in assays where ladder detection is set to Probe 2 (19257) 

 



Known Issues 
1. When special characters are used in run file name, Peggy Sue will not play separation movie 

correctly (21653)  

Solution: Do not use special characters in run file name 

5.0.0 Compass for SW Released July 21, 2020 

Features 
 

1. Support for the new RePlex™ feature on Jess, providing the ability to run two immunoassays 

within the same capillary to get all your rich protein characterization data from just one sample! 

• Quantify expressed phosphorylated target and total target levels 

• Normalize your data with total protein expression data in the same capillary 

• Greater flexibility in immunoprobe selection 

• More data points per sample 

• Save time and money on consumables 

NOTE: RePlex™ assays are not supported with Access Control enabled. 

 

Improvements and Fixes 
 

General 

1. Capillaries table displays the aligned position value for Standard Peak 1 position, which is 

slightly different from the position index value displayed in the Peaks table (17605) 

2. Sample fitted peaks for Run Report incorrectly display when user selects Baseline Fit option in 

View Menu for graphs (16986) 

3. Fitted peaks are not displayed in Run Report, even though Fitted Peak option is selected (17734) 

4. For Jess assays, automatically expand the Detection node by default to help the user review 

exposure and ladder settings (18122) 

5. Exclude Ladder lane from contrast adjustment to accommodate where user was unable to see 

ladder peaks in Lane View when sample peaks are 30 times higher or lower (4566) 

6. Resolved issue where Graph would show peak values when not selected in Graph Options 

(9825) 

7. Removed Diagnostic option in View Menu for Capillaries table (18509) 

8. Fixed issue where same peak label is displayed twice in Graph view (18441) 

9. Assay Protocol for Wes Total Protein - "Primary Antibody Time" should be named as "Antibody 

Diluent Time" (17687) 

10. Resolved issue where Standard Curve becomes empty when uses switches from Samples to 

Standards view (16055) 

11. Resolved an issue where the PN Sample peaks corrected area values would change when 

Protein Normalization is disabled.  This was incorrect, the value for these peaks do not change.  

This will not affect data when using the Protein Normalization feature in Jess (18805) 

12. Analysis Settings for Peak Names - Loading Controls will present previously enabled loading 

controls as enabled in non-selected peak groups. (18938, 18986) 



13. For Peggy Sue/Sally Sue/NP1000 assays, display warning message when sample load time is 0 in 

the assay protocol (18223) 

14. Name Peak > New option should exclude ladder capillary (17953) 

 

CFR 

1. Audit Trail – improved message for Send Run to include same information as Send Logs (e.g.  

send_runfile | Uploaded run for [SN], [path] [*.cbz]) (18236) 

 

Known Issues 
 

General 

1. IV Plot title for Jess non-RePlex run is "Cycle 1", not blank. (18962) 

2. History Log - Manual standard changes log message is not easily understandable. (18882) 

3. Add Run - Scale incorrect when run files of different sizes are added. (18915) 

4. Report will include legacy “Registration” Standards, although they are not used in analysis, nor 

are they visible in the Analysis Settings - Standards for Jess or Wes. (18836) 

5. If the user creates a name of the form Cn (such as C1) in the assay template, that name cannot 

be used in the Caps filter for Peak Names in Analysis Options (18753) 

6. Analysis Settings for Peak Names -> Standard Curves -> Concentration - units of precision do not 

match report. (18905) 

7. Analysis Settings for Peak Fit - Apply Override range changes are not properly applied to selected 

caps. (19024) 

8. It is possible for Peaks to be improperly labelled if user adds more manual peaks than there are 

ladder peaks. (18050)  

9. It is possible for the check-mark next to a ladder cap to not be removed when ladder peak 

changes are removed (18996) 

10. When trying to force a small/non-existent peak as a ladder peak, analysis will sometimes have 

issues finding the previous Ladder peaks 

Solution: Select Clear from context menu to remove the manual peak (19109) 

11. Electropherogram graph scaling issue when viewing multiple run files and one of the run files is 

not properly aligned to standards. (16351) 

12. Start Assay and Blot dialogs can be displayed at the same time. (17467) 

13. Plot Label display is cut off on left side of the plot when Ladder Capillary is set to ‘None’ and a 

single capillary is selected.  This only applies for Wes and Peggy Sue run files. (16850) 

14. ANDI export: In certain cases, peak positions may show slight difference between Compass for 

SW and Empower/Chromeleon due to peak detect/find algorithms with different software 

packages used for analysis (18873, 16048) 

15. Add runs – ‘save’ and ‘close all’ operations  

• Save button will not be enabled for Add Runs when only one file is modified (19042) 

Solution: Close the run file that has not been changed, this enables save button for the 

changed one. The user can then save and close. 

• Selecting File->Close All does not close all the files after saving (19048) 

 



RePlex™ 

1. Plot colors for RePlex runs may not be in the order expected. (18943) 

2. For RePlex assay data, Loading Controls can be used to correct the peaks of the same capillary, 

for both Probe 1 and Probe 2.  When multiple Loading Controls are defined across Probes, 

corrected area results for some capillaries can be incorrect (18989) 

3. Unable to make manual ladder changes for ladder capillary for RePlex assays with Total Protein 

when all channels are selected 

Solution: Temporarily unselect the Total Protein channel, then the context menu appears, 

allowing the user to make any necessary changes (19434) 

 

Lane 

1. Named Peaks are not displayed in Lane View when viewing multiple run files, even if the Named 

Peaks option in Lane Label dialog is selected. (16227) 

2. Contrast enhancement tool in Lane View is currently implemented for single run file only, does 

not work as expected when viewing data from multiple run files via Add Run capability 

Solution: Use the same fixed contrast levels for added runs (16226) 

 

2.0 Jess Instrument Software 
NOTE: Requires Compass for SW version 5.0 for RePlex assays.  Compass for SW software versions 4.1.0 

and lower cannot process Jess instrument run files from 2.0 embedded software 

Features 
 

1. Instrument support for RePlex assay (17721) 

2. Create explicit cleanup cycle for RePlex assays, which will include an assay node to specify the 

polymer location (17723) 

3. Add parameterized assay nodes and action blocks/units for RePlex Purge and Biotin Labeling to 

support ChemiIA+TP assay type (17766, 17815) 

 

Improvements and Fixes 
 

1. Increase low vacuum self-test summary data precision to 3 digits (17790) 

2. When the door is open at power-on for the instrument, the light output from the High-Power 

LEDs can be less than expected.  To mitigate this issue, the embedded software will now turn 

the HPLED on to 100% briefly when the instrument door closes (17876) 

3. Include self-test module exceptions in log files when running tests (18091, 18107) 

4. Save specific and unique filenames for each filter alignment test image to aid in troubleshooting 

(18367) 

 

  



Known Issues 
 

1. On rare occasions when attempting to close the door, the instrument will not properly 

recognize the hand sensor input and close (17590) 

 

4.1.0 Compass for SW Released September 25, 2019 

Features 
 

1. Online User Guide and Release Notes (16920) 

2. Added feature (Help -> Send Run File) that allows customers to send run files directly to 

ProteinSimple for Technical Support, utilizing a secure cloud storage location (17392) 

 

Improvements and Fixes 
 

General 

1. Improved the Jess Start Run dialog for barcode warnings for plate and cartridge (16597) 

2. Compass for SW now prevents multiple users or instances of the software from editing the 

same run file (*.cbz) (17120, 17537) 

3. Resolved issue where user could not print Run Reports (16643) 

4. Fixed issue where user modified (add/remove) baseline points and changes are not saved 

properly for Fluorescent channel data in Jess (16475) 

5. Resolved issue where the user could not logout from the application when there is an issue with 

a user account that is currently logged in (17125) 

6. Resolved case when Compass for SW software attempts to save an incomplete run file that has 

not been properly downloaded from the instrument. For this version, Compass will not allow 

the user to Save the file when it is incomplete (17124) 

7. Compass for SW now prevents the user from overwriting an existing assay or run file via the 

File->Save As… menu operation (17068) 

8. Resolved issue where access to Error logs option in instrument properties dialog is not present 

when connected to non-Jess instruments.  To access these logs, click on Logs in the Instrument-

> Properties… menu option, then click ‘All Logs’ button to access list of all log files (16387) 

9. Fixed issue where the Start run dialog would not recognize cartridge and plate barcodes if 

communication to instrument is lost and re-established (17267) 

10.  Fixed issue where the Start button in the Start Run dialog is disabled if communication to 

instrument is lost and re-established (16999) 

11. Compass for SW will now detect and prompt user when any default assay file is manually 

deleted or modified (17047) 

12. Fixed issue where Compass would display Null Pointer Exception (NPE) error when forcing 

Standards for the Ladder capillary (16634) 

13. Fixed issue where Standards image capillary locations (yellow box) move when IR data channel 

is selected on Jess (16617) 

14. Fixed dialog display title for ‘Assay – Detection Profile’ (16697) 



15. Improved consistency with ‘Assay – Detection Profile’ title to display (Chemi), similar to (NIR) 

and (IR) (17401) 

16. Fixed issue where reports cannot be generated for Peggy Sue, Sally Sue, and NP1000 completed 

run files with embedded software version 4.0 (17543) 

17. Fixed Run Report issue where 4PL standard curves are displayed as Linear (17579) 

18. Resolved issue when Ladder Capillary is set to ‘None’ for Peggy Sue or Wes run and changes 

made to the Peak Fit View region are not applied to the graph (16851) 

NOTE – As the Lane View contrast calculation is based on the Analysis View region, Lane View 

images may look slightly different when compared to images in version 4.0 (17673) 

 

CFR 

1. Improved Authorization Server Audit Trail messages to include full file path for sign_off, 

save_assayfile, save_runfile, open_assayfile, and open_runfile events (17119) 

2. Fixed issue where duplicate start run log entries are listed in Run Summary History (17450) 

3. Fixed issue where Compass for SW starts an uncontrolled run file when Access Control is On.  

This happens if communication to instrument is lost and re-established when Start Run dialog is 

open (17122) 

4. Start button for standard capillary cartridge assay in Start Run dialog is now disabled if a blot 

cartridge is present in the instrument (17438) 

5. Compass for SW now records Export Uncontrolled action in History log and Audit Trail (17121) 

 

Known Issues 
 

1. Capillaries table displays the aligned position value for Standard Peak 1 position, which is 

slightly different from the position index value displayed in the Peaks table (17605)  

2. Electropherogram graph scaling issue when viewing multiple run files and one of the run files is 

not properly aligned to standards (16351) 

3. Start Assay and Blot dialogs can be displayed at the same time (17467) 

4. Sample fitted peaks for Run Report incorrectly display when user selects Baseline Fit option in 

View Menu for graphs (16986) 

5. Fitted peaks are not displayed in Run Report, even though Fitted Peak option is selected. 

Solution: Check option to un-select and select again (17734) 

6. Plot Label display is cut off on left side of the plot when Ladder Capillary is set to ‘None’ and a 

single capillary is selected.  This only applies for Wes and Peggy Sue run files (16850) 

7. Named Peaks are not displayed in Lane View when viewing multiple run files, even though 

Named Peaks option in Lane Label dialog is selected (16227) 

8. Contrast enhancement tool in Lane View does not work as expected when viewing capillary 

data from multiple run files (16226) 

 

  



1.2 Jess Instrument Software 

Improvements and Fixes 
 

1. Added Fluorescence LED calibration routine (17070) 

2. Prevent condition where Compass for SW can start a new Assay run.  Jess instrument now 

ensures cartridge barcode image is completed before starting a new run (16581) 

3. Resolved issue where some system log files were not being rotated properly (17067, 17034) 

4. The Unregulated Vacuum Test can sometimes fail because a single calibration was being used 

for two vacuum sensors.  Modified to calculate the calibration curve for both sensors 

independently (17045) 

5. Improved reliability and robustness of closing the door for Jess instruments (17109) 

6. Modified Lamp PWM range for Borofloat solarization effects on Jess (17110) 

7. Fixed issue where calibration could not be performed on instrument the day before the Light 

Saber tool expires (16633) 

8. Added capability to detect background artifacts from cartridge (17269) 

9.  Display Instrument name in service console browser tab page title for main page (17436) 

10. Add log entry in embedded.log file for r-squared when determining pump curve in instrument 

high vacuum calibration routine (17434) 

11. Modified high vacuum calibration routine to include additional venting and settling time when 

determining setpoint (17452) 

12. Added log entries for any exceptions encountered in Camera Focus Calibration setup (17484) 

 

Known Issues 
 

1. On rare occasions when attempting to close the door, the instrument will not properly 

recognize the hand sensor input and close (17590) 

2. On rare occasions, the Jess instrument will not boot properly after a power cycle, displaying 

purple on the instrument status light.  Contact Technical Support for further troubleshooting 

and resolution (17040) 

 

4.1 Peggy Sue/Sally Sue/NP1000 Instrument Software 

Improvements and Fixes 
 

1. Resolved issue where some system log files were not being rotated properly (17067, 17034) 

2. Fixed issue where dark background images were not being cropped (17066, 17492) 

 

4.0.1 Compass for SW Released August 9, 2019 

Improvements and Fixes  
   

1. New user guide has correct reference to EMC standard (17614). 

 



4.0.0 Compass for SW Released June 8, 2018 

Features  
   

1. Support for Jess instrument – application support for two-color fluorescence detection, protein 

normalization, expanded self-test, cartridge information tracking, and traditional western blot 

imaging. 

2. Analysis Options panel - Allows for easier access to channel exposure selection and peak naming 

from the Analysis view without having to open the preferences dialog. 

3. Ability to name peaks from Graph/Lane view and Peaks table 

4. Improved layout and organization of Analysis/Preferences dialog. 

5. Support for multiple Standard Curves. 

6. Ability to configure Auto Lock Inactivity timeout in Preferences.  Default value is 20 minutes. 

7. Display of peak name labels in Lane View 

8. New Export logs feature, allowing the user to gather all logs from the instrument and Compass 

into a single file.  

9. Improved grouping and configurability for generating Run Report. 

10. Support for encryption of PDF file for Run Reports 

11. For advanced users, ability to view multiple channel images. 

 

Improvements and Fixes 
 

1. Improvements to High Dynamic Range analysis - HDR 4.0 handles a wider range of burnout 

cases. HDR 4.0 is less sensitive to the level at which burnout occurs. When burnout occurred at 

a low level the classical HDR method had trouble picking the optimal exposure and interpolating 

between exposures (13882, 14941, 14856, 14963, 9905, 9794) 

2. Improved Standards peak find – additional detection and correction of outliers (9469) 

3. Peggy Sue/Sally Sue – support Ladder settings per cycle, so that user can have different ladder 

cap settings for different cycles.  Allows user to fix data if the ladders for one or more cycles are 

bad or missing (4770, 4771) 

4. Assay Protocol – removed user ability to modify wash related steps for Wes/Jess assays.  This 

was done to prevent instrument failure when too many washes were specified by the user 

(10143) 

5. Increase pI precision on graph and header to match Peak Table (13884) 

6. Adjust Lane View contrast scaling to the current selected view region (8093) 

7. Resolved NPE error where user was unable to analyze and display data for a Peggy Sue run with 

Capillary boxes empty error (10327) 

8. Corrected immobilization wash load time for 13 cap assay (13943) 

9. Resolved issue where grouping order shown in Peak Groups was not consistent with Cap Groups 

and Capillary Groups (9975) 

10. Resolved issue where Charge Assay - Separation Type Voltage is not supported on Peggy Sue. 

User would see a Java NPE error upon changing the exposure time (14985) 

11. Resolved issue where peak labels and peak results disappear for the ladder cap after adding a 

ladder peak on graph (14005) 



12. Hide "Cycle" column in Experiment pane for single-cycle runs (3700, 4017, 4297, 15100) 

13. Added support for fractional time zones (15902) 

14. Resolved issue where Compass does not properly display the Instrument date and time after 

using ‘Set to PC Time’ function (15965, 15922) 

 

NOTE: ‘Check for Updates’ feature in Compass software will not update to version 4.0.0.  User will 

need to download installer from ProteinSimple website 

(http://proteinsimple.com/compass/downloads/) and perform a full installation. 

 

3.1.8 Compass for SW Released June 8, 2018   

Improvements and Fixes   
 

1. Access Control – resolved issue where login button is enabled after user enters in a value in the 

password field and then removes the entry (15678) 

2. Resolved issue where Lane View label font is corrupted after applying Windows 10, April 2018 

update, version 1803 (15690) 

 

3.1.7 Compass for SW Released December 15, 2016   

Features  
   

1. New High Dynamic Range (HDR) Detection Profile for size and charge assay (Wes, Peggy Sue, 

Sally Sue) 

 
 The Detection profile is set as default and can be disabled from the Assay protocol and replaces the 

old Multi-Image Analysis. For Wes, the higher dynamic range is achieved by using a more effective 

algorithm to create the High Dynamic Range multi-image analysis, refresh substrate from the assay 

plate prior to each exposure and minimizing the time between substrate aspiration and Image. No 

substrate refresh takes place in Peggy Sue and Sally Sue.  

For Wes, the embedded or instrument software must be updated to v2.5 or higher.  

Old runs (performed with Compass for Simple Western v3.0 or Compass v2.7 or older) can be 

analyzed with the new algorithm for High Dynamic Range.  

The substrate refresh requires that 15 μL of substrate instead of 10 μL be loaded /well for all 

Wes assays. A window with a warning to check for correct volume pops up after the Start run 

button is pressed.  

 

  



3.0 Compass for SW Released August 15, 2016   

Features  
   

1. New name and logo  

 Old =  Compass       New =  Compass for Simple Western     

2. Support for Low MW assay   

a. New assays for Low MW 2-40 kDa are added for Wes, Peggy Sue, and Sally Sue.  

b. Split buffer choice eliminated since it’s the default buffer for all assays.  

NOTE: Embedded update to v3.4.29684 required for Peggy Sue and Sally Sue to run new 

Low MW assays  

NOTE: Low MW runs generated by v3.0 cannot be opened with Compass v2.7.   

3. Multiple Exposure View 

Turn on “All Exposures” view from Graph Options - checking this option will overlay all the 

chemiluminescence exposure times acquired for a particular run. The peak that corresponds to 

the exposure time selected in the Analysis window under Images will be outlined in blue and the 

Peaks table below the graph window displays the data corresponding to the selected exposure 

time 

4. Run Reports - run report in PDF  

a. New menu item – File > Run Report…  

b. Run Report dialog – options for report sections and report name  

c. A PDF report is created with the options specified.  

5. History Details - Old and new values changed in Analysis Settings are logged 

6. Command Log - Added “Save File As…” button to save the log file 

7. Peak Fit View Options 

a. Added a “View” setting to control the default view to Full or Analysis.  

b. Added an “Apply” button to see analysis changes without closing the dialog.  

c. Removed the “Restore Original” button.  

8. Grouping Options Moved to Preferences - Simplified the Grouping command to toggle the 

Grouping display without a dialog 

9. Lane Contrast in Analysis window - Edit>Analysis>Lane Contrast  

Check the radio button for Fixed Level. The numbers displayed refer to the current White and 

Black levels for the run being analyzed. Change these settings and click Apply to see how they 

impact the contrast on the lane view. Once satisfied with the changes, click OK. When the you 

select Fixed Level, the slider tool is no longer available in the lane view.     Lane Contrast 

settings from the assay or run analysis windows can be exported to be applied to other assays 

or runs.  

NOTE: Files created or saved with the Lane Contrast feature locked cannot be opened by v2.7. 



10. Raw Baseline 

Improvement in how the raw baseline is calculated. Raw baseline for the shortest exposures is 

shifted (typically lower than previously observed if you are looking at a data obtained with a 

prior version). That said, the peak area for all exposures will remain the same and will not be 

affected by the shift of the raw baseline. Area to baseline ration, on the other hand will change 

from previously calculated with earlier versions of the software. 

11. Other Misc. Changes 

a. Allow size analysis without ladder peaks. Standards for fitting will be used for MW.   

b. Cleaned up peak table so only Standards or Registration peaks are displayed in peak 

table.  

c. Reduced the plot line width of exported graph.  

d. Renamed the view menu items and changed the corresponding icons on the toolbar.  

i. View > Multiple View has been renamed as View > All  

ii. View > Single View has been renamed as View > Selected  

e. Added a Self Test Confirmation dialog.  

f. Added a “Save File As” button in Command Log dialog to save the log.  

g. Added the instrument software version to Comment in Command Log after software 

upgrade  

 

2.7 Compass Software Released August 31, 2015  

Features 
 

1. Support for Split Running Buffer assays for Peggy Sue and Sally Sue and Wes size assays. Peggy  

Sue and Sally Sue also require embedded software v3.3 or newer  

a. “Split Running Buffer” will be displayed on the column header for split running 

buffer assays.  

b. “Upper RB” and “Lower RB” will be displayed in the Start Wizard for split 

running buffer assays.  

c.  “Split Running Buffer” will be displayed in Kit Info for the runs with split 

running buffer assays.  

d.  “Split Running Buffer” will be appended to the Plate S/N Info for Wes runs  

2. Export and import assay template now supports *.csv and *.txt formats  

3. Support copy and paste assay well contents from Excel and between Compass windows, 

including both names and attributes 

4. Fixed bug to make it possible to create a view for Group Plot if the group statistics for one of the 

groups is zero 

5. Fixed bug that created Duplicate Peak Name columns in Capillaries table when there are 

multiple identical peak names  



 

2.6.8 Compass Software Released July 24, 2015  

Features 
 

1. Wes plate barcode is captured for runs with embedded software v2.2.25328 and newer. Plate 

S/N number is displayed after run is complete in the Run Status tab.  

2. View Region – Lower and Upper values now reflect the option selected (Analysis, Full, or 

Custom). Previously only custom values are displayed.  

3. Download and open last completed run if Compass was disconnected during the run.  

4. Fixed bug that caused manual standards to be lost after reanalysis, if Analysis dialog was 

cancelled previously.  

 

2.6.7 Compass Software Released May 31, 2015  

Features 
 

1. Support Pipet Wash for Sally Sue and Peggy Sue instruments, with instrument software v3.2 and 

up.  

2. This release changes the default Size and Total Protein assays for Sally Sue and Peggy Sue to be 

compatible with Running Buffer 2 Rev B (Size and Total Protein assays 12-230 kDa). When 

File>New is selected, Rev. B assays will be created.  

 

2.6 Compass Software Released September 15, 2014  

Features 
 

1. Support for new Total Protein Size assays.  

2. Support for new 66-440 kDa Size assays.  

3. Support for updating instrument software from Compass  

 

2.5 Compass Software Released January 31, 2014  

Features 
 

1. Support for new instrument, Wes  

2. Support for new instrument, Sally Sue  

3. Support for new instrument, Peggy Sue  

4. New Loading and System Control functionality  

5. New standard curve fit functionality 

 

2.4 Compass Software Released June 28, 2013  

 

1. Support for 21 CFR Part 11 



 

2.3 Compass Software Released November 30, 2012  

 

1. Support for new instrument, Peggy 

 

2.2 Compass Software Released June 30, 2012  

 

1. Support for new instrument, Sally 

2. New grouping and statistics functionality 

 

2.1 Compass Software Released November 30, 2011  

 

1. Lane view improvement for sizing data 

 

2.0 Compass Software Released October 31, 2011  

 

1. Support for new instrument, Simon. 


