Release Notes – Compass for iCE software
Version 3.0.0
Released July 2022

Minimum PC requirements
Operating System
Processor
Memory
Free Disk Space
Ethernet Ports

Windows 10 64-bit
Core i5
8 GB
250 GB
2 (One for connection to Maurice, second port for network access)

Installation
Open the installer file to start the installation.
NOTE: To see latest installer version, select ‘Check for Updates’ in Help menu. If you don’t have internet
access, contact ProteinSimple sales or support team for assistance.

3.0.0 Compass for iCE Software
Features
1. Added Turbo CE-SDS cartridge support in Compass for iCE to enable Turbo SDS cartridges runs on
Maurice instruments (CFI-282).
2. New standalone post run cleanup method is added to cIEF cartridges (CFI-327).
3. Added recommendations to perform post run cleanup process for all cartridge types (CFI-398,
CFI-394)
Note: For CE-SDS and SDS Plus, Instrument menu item name 'Cartridge cleanup' is changed to
'Cartridge post run cleanup' (CFI-328).
4. When a post run cleanup step is skipped, a warning is displayed in run summary and reports for
all cartridge types (CFI-464).
Note: Different post run cleanup warnings will be displayed when cartridge cleanup is aborted or
failed (CFI-653, CFI-513, CFI-512).
5. Cartridge Self-Test option is added for cIEF, SDS, SDS-PLUS, & Turbo CE-SDS cartridges (CFI-465,
CFI-364, CFI-335).
6. Cartridge serial number column is added in Instrument Logs dialog to support new cartridge selftest (CFI-525)
7. If pressure or vacuum fails to reach target pressure during the run, a warning is displayed in the
Run Summary perspective (CFI-552)
8. Added ‘Export logs’ and ‘Send Run File’ options in the help menu to facilitate sending zipped log
files and run files directly to ProteinSimple Technical support (CFI-443, CFI-342)

Note: ‘Compass for iCE Log’ option in the help menu is removed (CFI-483) as log files can now be
saved locally using ‘Export logs’ feature.
9. ‘Graph Options’ and ‘Lane Options’ (for size cartridge types only) selections are now saved with
the batch and injection run file, so that user preferences are saved for the next time the run file
is opened (CFI-216)
10. Lane view option is added in the injection report. In cases of 96 injections, lane view image is
printed in two 48 injection image views (CFI-215)
Note: Lane view option is not supported for auto reports.
11. Compass for iCE can now securely connect to Compass Authorization Server for iCE (CFI-686).
Note: If Compass for iCE tries to connect to older version of CAS, a warning is displayed that
Compass Authorization Server is out of date and is connecting in insecure manner (CFI-511)

Improvements and Fixes
General
1. Updated post run clean up dialogs for CE-SDS with emphasis on performing post run cleanup
after each run (CFI-388)
2. An information dialog will be displayed at the end of the run if the selected folder is deleted
during the run and then run file gets saved in the default location
C:\Users\..\Documents\Compass for iCE\Runs. (CFI-241)
3. Compass for iCE will save run file with unique name in downloads folder if it identifies an existing
file with same name (CFI-340).
Note: Start button will be disabled in start run dialog till unique results file name is entered as a
preventive measure to avoid duplicate run files at the end of run (CFI-248, CFI-290, CFI-362)
4. Grouping of data now reports Corrected area instead of Raw Area (CFI-231 or 19157)
5. Added error dialog to inform that newer batch files cannot be opened in unsupported versions of
compass (CFI-691)
6. Fixed an issue with peak height calculation where peak height did not subtract the baseline when
interpolate peak fit setting was applied (CFI-291)
7. Export Spectra -Text Format: RMT values are now exported correctly in "Sample Baseline
Corrected vs RMT" table (CFI-145)
8. Removed unused Log4j library from code to avoid any vulnerability threats (CFI-506)
9. CE-SDS Lanes - Fixed display issue of overlapping peak labels for peaks that have same or similar
RMT or MW values (CFI-270)
10. Updated view in Method Groups table to list items in the order of method names instead of peak
names (CFI-523)
11. New shortcut keys (Ctrl+O and Ctrl+Q) are added to enable user to perform open run and
application exit operations (CFI-447)
CFR
1. Added ‘Stop run’ and ‘Start run’ entries in audit trail (CFI-564)
2. Added cartridge post run cleanup status entries (CFI-624) and cartridge serial number (CFI-441)
info to the audit trail

History logs
1. Added History log message for "Moved Marker" for CE-SDS Markers when opening run file from
version 2.0 and earlier (19236 or CFI-242)
2. Added Baseline type in History log when creating a new peak fit group (19237 or CFI-243)
3. Added Compass version to Run Summary History Log for Started run log message (CFI-570)
4. Fixed repeated entry issues in analysis log and run summary history (CFI-578 and CFI-598)
Reports
1. Instrument Report now includes Cartridge Clog self-test reports (CFI-379)
2. Added more details in footer - software name and version number, secure status of PDF and the
location of the report file (CFI- 273)
3. Instrument Report will not include Cartridge Info if Cartridge is not present in the instrument
(CFI-519)
4. Fixed the issue of when generating Injection Reports, the selected injections number does not
always match the selection in the Experiment table (18744 or CFI-217)
5. Added error message when attempting to save Injection Reports or Export
Batch/Methods/Injections to a read-only folder (19215, 19171 or CFI-239, CFI-395)

Known Issues
1. Raw Peak Area calculated for CE-SDS data in Compass is 2x difference from Area calculated in
Empower. Compass calculates area based on data rate of 2 Hz, where Empower calculates based
on time of 1 second (16590)
2. On rare occasions, some File and Instrument menu options are disabled after the run completes.
Should you encounter this, simply restart Compass and the menu options will be available again.
(17061 or CFI-229)
3. If the user stops a Cartridge Purge operation via Instrument->Emergency Stop, the Compass
software will not automatically prompt the user to perform another Cartridge Purge operation if
required (16501 or EM-10)
4. Unable to Save As for opened run when opened folder not reachable (19219 or CFI-240)
5. Peak Fit Range cannot apply range of min and max for more than one group (18791 or CFI-396)
6. In some cases where there is a large spike in the data outside of the Marker range, the Marker
peak is mislabeled for the injection in the Samples -> View All display (17732 or CFI-397)
7. Injection Groups - Sample group names not displayed or incorrectly displayed for some runs (CFI468)
8. Export data format can in incorrect in German locale. (CFI-663)
9. When language is set to German, pI values in new peak information entry may not display
correctly due to comma and decimal rules (CFI-690)
10. Data export will not display names correctly in Chinese locale (CFI-692)
11. Occasionally an exception may occur when ‘Instrument->Disconnect’ operation is performed at
the end of the run (CFI-456)
12. Export Spectra folder name can be incorrect when multiple run files are opened (CFI-689)

13. Ctrl + O operation in Batch perspective opens 'Open Batch File' window instead of 'Open Run
File' window (CFI-572)
14. In runs where samples have very less data, CE-SDS Lane View may not display last two peaks of
MW ladder. Table and graph data is displayed correctly. (CFI-738)
15. Java heap space error occurs if one tries to open 25 run files of Turbo batches with 96 injections.
Recommend opening no more than 15 run files at a time (CFI-702)
16. In run summary view of a controlled run file, batch name is not displayed correctly (CFI-707)
Reports
17. When the user has selected to create an Injection Report that includes Fitted Peaks and a
method that does not have any FL exposures, a Null Error will display. Should you encounter this,
simply unselect the Fitted Peaks selection in the Injection Report (17052 or CFI-228)
18. Blank pages appear in the lane view part of report if number of injections are less than 48 (CFI561), in cases where instrument or Cartridge checkbox is not selected (CFI-637) and in runs with
very few injections (CFI-736)
CFR
1. No Audit Trail messages are recorded for import/export of methods (18920 or CFI-255)
2. There is no Audit Trail log entry for creating a new Batch in Compass for iCE (19200 or CFI-234)
3. Manual Peak changes are removed and logged in history after importing analysis settings (19238
or CFI-660)

4.0 Maurice Instrument Software
Features
1. Support to perform Turbo CE-SDS cartridge runs from Maurice instrument (EM-46).
2. Support to perform post run cleanups and cartridge self-test to improve the quality and
durability of the cartridges (EM-12)

Known Issues
1. PC time zone changes may not be updated correctly in progress bar and status tab of the run.
However, there is not impact on run duration (EM-134)
2. Cartridge self-test time displayed in progress bar is only an estimated time of completion and
may differ from actual time taken for self-test for each cartridge type (EM-142)

2.2.0 Compass for iCE Software
Features
1. Added reconstructed pseudo gel view display for CE-SDS and CE-SDS PLUS application data. This
display is an image used for quick qualitative visualization or results, not for quantitation or
reporting (16142, 16222)
2. Ability to configure whether Batch and Injection reports are secured by a random password upon
creation. Report footer will indicate whether the report PDF was generated with or without the
(SECURED) option (18135, 18734, 18345)
3. Compass for iCE will automatically create a single, combined report PDF file with the included
options selected by the user for Injection Reports (17572, 17559, 18332)

4. When naming Injection Report filenames, the software will append sample ID to the name the
PDF report generated (17982)
5. Created new group in Analysis Preferences -> Analysis Export to give the user the ability to
specify Y-Axis units for Absorbance values for ANDI export (17651)

Improvements and Fixes
General
1. Resolved minor discrepancy in the Peak Position value shown in the Compass for iCE Peaks table
and the data exported using File -> Export Tables function (18658)
*NOTE: For both the ‘Markers’ and ‘Samples’ view Peaks table, we have modified the
application to display the Peak Position, and corresponding Height, as the value found from the
peak fit step, not the peak find step in the peak detection algorithms. This value is an
interpolated pixel position value and is what is currently being exported to the text files when
using File -> Export Tables. For consistency, the Peak position values are now displayed AND
exported with #.0 precision.
2. For CE-SDS runs, draw Internal Standard (IS) graph line to match time value in Peaks table
(19097)
3. Resolved issue where Batch Injection IDs and Injection Names are not updated correctly when
user switches plate type, e.g. from 96-well plate to 48 vials. (18638)
4. Fixed issue where loading Batch file from version 2.0 and earlier with a combination of OBM and
non-OBM injections would not load and display properly in version 2.1 (18714, 18924)
5. Fixed issue with the Analysis Options Injects field in distinguishing between a custom filter
expression and a name. If the name is made up of only characters that can occur in a custom
filter expression, the name is interpreted as a custom filter (19203)
6. Resolved compatibility issue for CE-SDS Markers Analysis Groups created with version 2.0 and
earlier. In version 2.1, when changing the Markers Injection to ‘no markers’, the Graph labels
would still display MW values, which is incorrect (19173)
7. Modified CE-SDS graph peak label precision for MW to be consistent with Peaks table (19160)
8. Fixed issue in Injection Reports where the date in missing in the footer when the username, first
and last name are greater than 30 characters. Re-arranged footer fields so that name
information and date are one line and will not run into other text (18599)
9. Resolved issue in Analysis Injections table where duplicate results are displayed for Injections
that have Methods with the same pI Markers (18716)
10. Additional check for missing run name prior to sending batch from Compass to instrument
(18358)
CFR
1. Fixed issue where “Added Marker” History log messages were incorrectly present when
migrating Marker definitions from version 2.0 or earlier (19191)

2. Resolved multiple incorrect History log message for CE-SDS Markers introduced in version 2.1
(19148)
3. Modification that requires the user to save a comment for unsaved changes in the Batch before
starting a run on the instrument (18202)
4. Improved the Audit Trail log entries for Injection reports, which now shows "All Injections" or a
list of Injections sorted by the Injection name in the list, as well as removing leading comma
(18742, 18346)
5. Improved consistency of creating Audit Trail log entries for reports. Compass for iCE application
will now create one line each for injection report, analysis report and batch report (18347)
Export
1. Resolved issue in creating export directory name with a colon in the name (17625, 17608)
2. ANDI export – fixed issue with export when Injection name has tab or spaces at the end, replace
these characters with underscore when writing file names (18549)

Known Issues
1. Raw Peak Area calculated for CE-SDS data in Compass is 2x difference from Area calculated in
Empower. Compass calculates area based on data rate of 2 Hz, where Empower calculates based
on time of 1 second (16590)
2. On rare occasions, some File and Instrument menu options are disabled after the run completes.
Should you encounter this, simply restart Compass and the menu options will be available again.
(17061)
3. If the user stops a Cartridge Purge operation via Instrument->Emergency Stop, the Compass
software will not automatically prompt the user to perform another Cartridge Purge operation if
required (16501)
4. Unable to Save As for opened run when opened folder not reachable (19219)
5. Peak Fit Range cannot apply range of min and max for more than one group (18791)
6. In some cases where there is a large spike in the data outside of the Marker range, the Marker
peak is mislabeled for the injection in the Samples -> View All display (17732)

Reports
1. When the user has selected to create an Injection Report that includes Fitted Peaks and a
method that does not have any FL exposures, a Null Error will display. Should you encounter
this, simply unselect the Fitted Peaks selection in the Injection Report (17052)
CFR
1. No Audit Trail messages are recorded for import/export of methods (18920)
2. There is no Audit Trail log entry for creating a new Batch in Compass for iCE (19200)
3. Manual Peak changes are removed and logged in history after importing analysis settings (19238)

4.0 Maurice Instrument Software
Features
1. Support to run instrument from Compass for iCE or Empower Maurice ICS Driver. Verification
testing completed for Compass for iCE version 2.2 and Empower Maurice ICS Driver version 1.0.
2. Support for optional Maurice CE-SDS System Filter (17860, 17842)
3. Production support for Mitac Single Board Computers (PD10AI and PD11TI) (18881, 1821618220)

2.1.0 Compass for iCE Software Released March 8, 2019
Features
1. Support for new CE-SDS PLUS system (* requires Maurice Instrument Software v3.1 listed below)
(16137)
2. Ability to import/export injections from Batch view. Injections in an open batch or run file can be
exported to a .csv file. This allows the user to import injections into another batch later, rather
than having to enter the information manually (16715)
3. Support for optional FL458nm fluorescence filter (* requires Maurice Instrument Software v3.1
listed below) (16140)
4. Manual Peak Integration features are now available when working on controlled files with Access
Control enabled. Any user activities related to moving the start/end of peaks will be logged in
the History tab view in Run Summary (16228)
5. Added new ‘Interpolate” option for Baseline type in Peak Fit analysis settings. When selected,
Compass for iCE lets you interpolate baselines from the base of each peak that use Dropped
Lines integration (16287)
6. Added new Reference Channel Signal Processing capability for CE-SDS data. When enabled, the
Reference Channel Correction automatically removes any signal within a certain range that can
be attributed to lamp variability (16132)

7. Added new Baseline Smoothing Signal Processing capability for CE-SDS data. When enabled, the
software applies baseline smoothing to CE-SDS data to decrease noise and improve signal-tonoise ratios. (16133)
8. Report PDFs generated by Compass for iCE are now secured. They can be viewed and printed but
can’t be modified (16143)
9. Ability to configure Auto Lock Inactivity timeout in Preferences. Default value is 20 minutes
(16304)
10. Support detection of CE-SDS cartridge that requires purge before use. If the CE-SDS cartridge
you have inserted into the instrument hasn’t been used in more than three months, Compass for
iCE will display an alert recommending you perform a cartridge purge (16138)
11. Added new ‘Cartridge Purge’ menu item under Instrument menu to allow the user to start a
purge protocol without having to open a batch (16380)
12. Analysis Options panel - Allows for easier access to exposure selection and peak naming from the
Analysis view without having to open the Analysis dialog (16498)
13. Support Peak Naming for selected peak on Graph or Peaks table (16307)
14. Online User Guide and Release Notes (16499)

Improvements and Fixes
General
1. Compass for iCE now prevents multiple users or instances of the software from editing the same
run file (*.mbz) (6905, 16919, 16941)
2. Compass for iCE now prevents the user from overwriting an existing batch or run file via the
File->Save As… menu operation (16722, 16743)
3. Improved cases where Marker/Standard peaks found in Markers/Standards view are not found
and displayed in Samples view (13205)
4. Automatically display self-test results after test has completed (16542)
5. Added "Injection" column to Group Tables (16869)
6. Modified default analysis settings for CE-SDS - Internal Standard Time has been changed to 750
seconds, from 710 seconds (17036)
7. Resolved issue where software would allow users to exceed CE-SDS batch limitations of 48
injections during the active run (16066)
8. Resolved Batch Report issue where replicates Sample ID are not displayed properly (16803)
9. Resolved case when Compass for iCE software attempts to save an incomplete run file that has
not been properly downloaded from the instrument. For this version, Compass will not allow the
user to Save the file when it is incomplete (15912)
10. Fixed NPE message and incorrect graph, warning, and peak results in the Analysis perspective for
cIEF run when one of the method definitions does not specify any Fluorescent images in the
Detection profile (15369)
11. Increase thermo wash time in CE-SDS Purge from 5 minutes to 10 minutes (16235)
CFR
1. Improved Authorization Server Audit Trail messages to include full file path for sign_off,
save_batchfile, save_runfile, open_batchfile, and save_batchfile events (16744, 16752, 16746,
16543, 16751)
2. Software provides warning messages for expired password, blocked user, and no permissions in
the Lock window (8858)
3. Audit trail and history log track Export uncontrolled file (16977)
4. Fixed issue in the Run History log, where analysis changes made during the Pause state of an
active run are not logged in the file properly (16171)
5. Fixed issue where the Audit Trail reflects the old filename when saving as a new run file (16729)
6. Resolved issue where the user could not logout from the application when there is an issue with
a user account that is currently logged in (16200)
7. Fixed issue where negative pI values in compass adversely affecting the calibrated data in
empower (16940)

Export
1. ANDI Export - Modified Y-axis labels from AU to mAU for Absorbance data, and Y-axis values
from AU to mAU for CE-SDS data only (15229)
2. Export Tables – Modified the value of the Position column in the exported text files ONLY to be
the interpolated pixel peak position. Note that the Position value in the Peaks table in the
Compass software displays the integer pixel peak position (11906)

Known Issues
1. Raw Peak Area calculated for CE-SDS data in Compass is 2x difference from Area calculated in
Empower. Compass calculates area based on data rate of 2 Hz, where Empower calculates based
on time of 1 second (16590)
2. The ‘Help -> Check for Updates’ function will not work to update to version 2.1.0 from Compass
for iCE version 2.0.11 and earlier due to changes in Java Runtime Environment (1.7 to 1.8) and
Eclipse RCP (3.7. to 3.8.2). Users will need to use installer for upgrade (16834)
3. On rare occasions, some File and Instrument menu options are disabled after the run completes.
Should you encounter this, simply restart Compass and the menu options will be available again.
(17061)
4. If the user stops a Cartridge Purge operation via Instrument->Emergency Stop, the Compass
software will not automatically prompt the user to perform another Cartridge Purge operation if
required (16501)
5. When the user has selected to create an Injection Report that includes Fitted Peaks and a
method that does not have any FL exposures, a Null Error will display. Should you encounter
this, simply unselect the Fitted Peaks selection in the Injection Report (17052)

3.1 Maurice Instrument Software
Features
1. Support for new CE-SDS PLUS system (16241)
2. Support for optional FL458nm fluorescence filter (16211)

Improvements and Fixes
1. Instrument support to double check Deuterium Lamp is ON before starting the run (15001)
2. Increase cartridge clean up water load times by a factor of 1.5x (16974)

2.0.11 Software Released October 26, 2018
Improvements and Fixes
1. Resolved issue where Compass software could not properly synchronize the instrument time to
the local PC time for fractional timezone offsets (e.g. India) – (15902)
2. Access Control – resolved issue where login button is enabled after user enters in a value in the
password field and then removes the entry (15678)

2.0.10 Software Released January 5, 2018
Improvements and Fixes
1. Fixed CE-SDS ANDI Export Time for Empower – ANDI exported CE-SDS data time unit was
erroneously modified to seconds in Compass for iCE v2.0, which causes issues with imported
data in Empower. This issue was not present in versions 1.0 and 1.1, and in version 2.0.10 this
issue was fixed by reverting to use minutes for ANDI exported CE-SDS data (13851)

2.0 Software Released June 28, 2017
Improvements and Fixes
1. Improved the 'Dropped-Lines' Peak Find Area calculation analysis .
a
Improvements to the baseline fit for run data - In some cases, versions 1.0 and
1.1 of Compass for iCE may incorrectly produce negative baseline values. The negative
baseline values are eliminated in Compass for iCE v2.0, by modification of the baseline
offset.
b
Improvements to the peak fit algorithm - In some cases, dropped Line peak fit in
versions 1.0 and 1.1 of Compass for iCE doesn’t fully calculate the area under the curve
(AUC) especially for peaks that have a long "tail". In Compass for iCE v2.0 the peak fit
algorithm is modified to improve the calculation.
* The changes in baseline value, and the dropped line peak fit in Compass for iCE v2.0,
may produce different peak area values compared to versions 1.0 and 1.1 of Compass
for iCE. Please inquire with ProteinSimple Technical Support if you would like further
supporting documentation and example data regarding these modifications.

Features
1. Runs can be paused to allow editing of the Batch and adding of samples.
2. Stopping a run performs cartridge cleanup automatically.
3. Each injection has a unique editable name.
4. The Injection Names and Sample IDs can be pasted from a list in Excel or other programs.
5. The Signal to Noise Ratio is reported for each peak.
6. Improved reporting
a. Added the time and temperature of each injection.
b. Added an option to plot the fitted peaks.
c. Added an instrument and cartridge report including self-test results.
d. New reports never overwrite existing reports.
7. Data and Reports can be automatically exported at the end of each run.
8. Enables manual peak integration via manual correction of peak start and end, including peak
combining or splitting.
9. cIEF has an increased FL calibration load time to ensure full loading.
10. CE-SDS has an increased wash time to maintain resolution and peak arrival time.
11. cIEF Absorbance and Fluorescence electropherograms can be overlaid.
12. Methods can be imported or exported among batches.

1.1 Software Features Released September 14, 2016
1. Enables the creation of on-board mixing batches for instruments that are on-board mixing
capable.
2. CE-SDS assay has an improved wash step which prevents occasional slow migration time after
extended storage.
3. cIEF assay actively monitors for bubbles during sample load greatly reducing the failure of
injections due to bubbles.
4. Automatic re-injection on failed cIEF injections with abnormally low current
5. Improvements to Reports
a. Title indicates a controlled or uncontrolled run
b. Injections indicate if they are within the guaranteed limit for the cartridge
c. The Run table includes the Compass user name for actions
d. Added page numbering, page x of y
6. Improvements to ANDI file exports
a. Added a Chromeleon 6.8 export preference that corrects the X axis to be in pI units
padded to start from zero.
b. Fixed a date format problem in the Spectra Export ANDI format that caused some
injections imported into Empower to corrupt the project.
c. Changed the cIEF absorbance data to be exactly the same as the ICE3 format by making
two changes:
i.

Changed the Spectra Export ANDI format to be an array of points starting from
zero with a value of zero until the first pI value.

ii. Changed the Spectra Export ANDI format y value to be AU not mAU.

1.0 Software CD Contents Released March 21, 2016
The CD contains the software installation file and the user guide.
NOTE - Key Improvements are listed in the Release Notes. For detailed Release Notes, including an
itemized list of ALL issues resolved in the latest release, please e-mail support@proteinsimple.com

